In a Phoenix context, we frequently need to create and update resources, using changesets.
Each operation requires a function to get the changeset, and a function to perform the operation. If the operation in question is “create”, the standard approach is to name the changeset function “create_changeset”, but that’s just confusing; am I getting a changeset for the “create” operation, or am I creating a generic changeset?
I prefer the following conventions: https://www.stephenlewis.me/blog/naming-phoenix-context-functions
Read next ThinkingElixir 133: Winning the ML Prise